Print | Rate this content

HPSBTU02322 SSRT080011 rev.2 - HP Tru64 UNIX running SSH/SFTP Server, Remote Execution of Arbitrary Code or Denial of Service (DoS)

SUPPORT COMMUNICATION - SECURITY BULLETIN

Document ID: c01404118

Version: 1

HPSBTU02322 SSRT080011 rev.2 - HP Tru64 UNIX running SSH/SFTP Server, Remote Execution of Arbitrary Code or Denial of Service (DoS)
NOTICE: The information in this Security Bulletin should be acted upon as soon as possible.

Release Date: 2008-03-26

Last Updated: 2008-03-26


Potential Security Impact: Remote execution of asrbitrary code or Denial of Service (DoS)

Source: Hewlett-Packard Company, HP Software Security Response Team

VULNERABILITY SUMMARY

A potential security vulnerability has been identified in the SFTP Server (sftp- server) component of SSH v 3.2.0 and earlier running on HP Tru64 UNIX. The vulnerability could be exploited by a remote user to execute arbitrary code or cause a Denial of Service (DoS).

References: CVE-2006-0705

SUPPORTED SOFTWARE VERSIONS*: ONLY impacted versions are listed.

The following supported software versions are affected:

SSH v 3.2.0 and earlier as provided with...

HP Tru64 UNIX v 5.1B-4
HP Tru64 UNIX v 5.1B-3

BACKGROUND

For a PGP signed version of this security bulletin please write to: security-alert@hp.com

CVSS 2.0 Base Metrics

Reference
Base Vector
Base Score
CVE-2006-0705
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
6.5

Information on CVSS is documented in HP Customer Notice: HPSN-2008-002.

RESOLUTION

HP is releasing the following Early Release Patch (ERP) kits publicly for use by any customer until updates are available in mainstream release patch kits.

The resolutions contained in the ERP kits are targeted for availability in the following mainstream kit:

HP Tru64 UNIX v 5.1B-5

The ERP kits use dupatch to install and will not install over any Customer Specific Patches (CSPs) that have file intersections with the ERPs. Contact your service provider for assistance if the installation of the ERPs is blocked by any of your installed CSPs.

The ERP kits distribute the following items:

Patched version of SSH v 3.2.0

HP Tru64 UNIX Version v 5.1B-4
PREREQUISITE: HP Tru64 UNIX v 5.1B-4 PK6 (BL27)
Name: T64KIT1001460-V51BB27-ES-20080310
Location: http://www.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT1001460-V51BB27-ES-20080310
HP Tru64 UNIX Version v 5.1B-3
PREREQUISITE: HP Tru64 UNIX v 5.1B-3 PK5 (BL26)
Name: T64KIT1001467-V51BB26-ES-20080314
Location: http://www.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT1001467-V51BB26-ES-20080314

MD5 checksums are available from the ITRC patch database main page. From the patch database main page, click Tru64 UNIX, then click verifying MD5 checksums under useful links.

PRODUCT SPECIFIC INFORMATION

HISTORY

Version:1 (rev.1) - 25 March 2008 Initial release
Version:2 (rev.2) - 26 March 2008 Updated patchkit links

Third Party Security Patches: Third party security patches which are to be installed on systems running HP software products should be applied in accordance with the customer's patch management policy.

©Copyright 2008 Hewlett-Packard Development Company, L.P.
Hewlett-Packard Company shall not be liable for technical or editorial errors or omissions contained herein. The information provided is provided "as is" without warranty of any kind. To the extent permitted by law, neither HP or its affiliates, subcontractors or suppliers will be liable for incidental,special or consequential damages including downtime cost; lost profits;damages relating to the procurement of substitute products or services; or damages for loss of data, or software restoration. The information in this document is subject to change without notice. Hewlett-Packard Company and the names of Hewlett-Packard products referenced herein are trademarks of Hewlett-Packard Company in the United States and other countries. Other product and company names mentioned herein may be trademarks of their respective owners.

Provide feedback

Please rate the information on this page to help us improve our content. Thank you!